| Subcribe via RSS

Apple compressor and h.264 strange 1px line problem.

September 4th, 2010 | 1 Comment | Posted in apple compressor

Apple Compressor is an awesome little encoder which comes along with Final Cut Studio bundle. I don’t use it all of the time but when I have a lot of rendering to do I usually lean towards using compressor. It’s got queue rendering and you can share the rendering between different machines etc. And did I mention it’s fast. So yeah I recommend it to anyone doing video production and wants to render stuff out for different media. But I’m not here to praise but rather talk about a strange problem I had.

The Problem

I’m rendering a h.264 video out to a flash website. I’ve done this before and it always works out as expected (sometimes making 3-4 test renders to see the quality/size ratio). This time however I get good quality as always, but also a thin 1px grey (or white) line is rendered into a video. I would not mind usually, but for this site and video you can really see the line when in fullscreen mode. And the video being really dark is not helping much. The grey line really stands out.

The Solution

Googling like a mad maniac and reading through tons of forums didn’t help. Finally I found an apple support discussion that handed me a solution.
It seems that h.264 video is compressing video in 16pxX16px chunks. So basically, if you give the encoder odd sizes to chew it’ll go a bit cuckoo with unexpected results. It’s not a problem with video when width and height can both be divided by 16. 
So when you are doing odd sizes, be sure to have both dimensions be a multiplication of 16 and you’ll avoid this annoying problem.

My dimensions:
1280X573 Failed with grey line on the bottom
when changed to:
11280X576 Perfect video.

Stupid problem with a really simple solution you just have to know.

Tags: , , , , , , , , , , , , ,
  • Ads